Installing/Upgrading From the PyPI

$ pip install polyglot


polyglot depends on numpy and libicu-dev, on ubuntu/debian linux distribution you can install such packages by executing the following command:

sudo apt-get install python-numpy libicu-dev

From Source

polyglot is actively developed on Github.

You can clone the public repo:

git clone

Or download one of the following:

Once you have the source, you can install it into your site-packages with:

python install

Get the bleeding edge version

To get the latest development version of polyglot, run :

$ pip install -U git+


polyglot supports Python >=2.7 or >=3.4.